Major Incident Tracking - Electronic Timekeeping (Kronos)
Incident Report for UCSB
Resolved
Issue with SSO has been identified and resolved.
Posted Apr 05, 2021 - 15:50 PDT
Investigating
We are experiencing issues with the timekeeping logon screen. Upon logging in users are directed to https://ucsb.kronos.net/wfc/navigator/logonWithUID

This issue is currently being investigated.
Posted Apr 05, 2021 - 15:17 PDT
This incident affected: Campus Business Applications (Electronic Timekeeping (Kronos)).