WebTMA - webtma.arit.ucsb.edu is down
Incident Report for UCSB
Resolved
This incident has been resolved.
Posted Jun 22, 2020 - 11:36 PDT
Investigating
Service Outage Notification
Posted Jun 22, 2020 - 11:01 PDT
This incident affected: Administrative Services Applications (iServiceDesk - WebTMA).