The BARC upgrade originally scheduled for this weekend has been postponed until further notice. Another announcement will be published once a new date is determined.
Posted Nov 23, 2019 - 12:30 PST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 23, 2019 - 09:00 PST
Update
We will be undergoing scheduled maintenance during this time.
Posted Nov 22, 2019 - 13:17 PST
Scheduled
MyBARC and eBill Users:
There will be an outage Sunday November 24th, 2019. We expect MyBARC and eBIll to be operational by Monday November 25th, 2019 at 8 am.
Posted Nov 18, 2019 - 11:48 PST
This scheduled maintenance affected: Campus Business Applications (BARC).