Major Incident Tracking - UCPath

Incident Report for UCSB

Resolved

This incident has been resolved.
Posted Jul 15, 2025 - 12:37 PDT

Investigating

Over the weekend, the scheduled UCPath July Release & Upgrade was completed. As a result of the upgrade, we are currently experiencing significant slowness within UCPath, and users are having trouble logging in.



The UCPath Center is actively working to resolve the performance problems as quickly as possible. We will provide updates as more information becomes available.

Thank you,

The UCPath Project Team
Posted Jul 14, 2025 - 08:47 PDT
This incident affected: Campus Business Applications (UCPATH).