iService Desk - WebTMA Request Site is down
Incident Report for UCSB
Resolved
This incident has been resolved.
Posted Nov 07, 2023 - 06:27 PST
Investigating
Service Outage Notification
Posted Nov 07, 2023 - 06:07 PST
This incident affected: Administrative Services Applications (iServiceDesk - WebTMA).