WebTMA - webtma.arit.ucsb.edu is down
Incident Report for UCSB
Resolved
This incident has been resolved.
Posted Jul 29, 2021 - 13:11 PDT
Investigating
Service Outage Notification
Posted Jul 29, 2021 - 12:42 PDT
This incident affected: Administrative Services Applications (WebTMA).