Unable to open files in Box

Incident Report for UCSB

Resolved

This incident has been resolved.
Posted Jun 13, 2025 - 07:16 PDT

Monitoring

Box reports that the issue is resolved. We are monitoring for stability.
Posted Jun 12, 2025 - 14:44 PDT

Investigating

Box is reporting issues with multiple services. We are receiving reports of people unable to open files in Box.
Posted Jun 12, 2025 - 11:46 PDT
This incident affected: Messaging, Collaboration, and Communication Services (Box Box Drive, Box Box Sync, Box Uploads/Downloads, Box Storage Services).