Major Incident Tracking - BARC
Incident Report for UCSB
Resolved
BARC is now Operational and Users can access the system.
Posted Jun 30, 2020 - 14:22 PDT
Update
BARC is currently unavailable due to technical difficulties. Please do not log in at this time.
Posted Jun 30, 2020 - 10:48 PDT
Identified
Issues affecting BARC operations have been identified
Posted Jun 30, 2020 - 10:33 PDT
This incident affected: Campus Business Applications (BARC).