Concur SSO Issue

Incident Report for UCSB

Resolved

This incident has been resolved.
Posted Mar 17, 2025 - 07:20 PDT

Investigating

We are aware that UCSB users are currently unable to log into Concur using SSO. We are working with Concur to fix the issue and will keep you updated.
Posted Mar 16, 2025 - 10:16 PDT
This incident affected: Campus Business Applications (Concur).