Gauchoprint Unavailable

Incident Report for UCSB

Update

Mobility print is unavailable on campus networks. PC's in the Library are available to print.
Posted Aug 28, 2026 - 16:16 PDT

Update

We are continuing to investigate this issue.
Posted Aug 27, 2026 - 10:10 PDT

Update

Campus printing is restored. Off campus printing is still unavailable as the investigation continues.
Posted Aug 27, 2026 - 09:53 PDT

Investigating

Gauchoprint is currently unavailable as we investigate a security concern. No ETA is available at this time.
Posted Aug 27, 2026 - 09:08 PDT
This incident affects: Student Business Applications (GauchoPrint).