Network connectivity to Ellison Hall Issue

Incident Report for UCSB

Resolved

Service to Ellison Hall has been restored.
Posted Nov 14, 2025 - 16:26 PST

Identified

Network connectivity to Ellison Hall failed at 2:43pm. Investigation indicates a network switch has failed, and a replacement will be installed. The estimated time for resolution is 5:00pm.
Posted Nov 14, 2025 - 15:44 PST
This incident affected: Campus Technical Services (Campus Network).