ServiceNow

Incident Report for UCSB

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 08:52 PDT

Update

ServiceNow is functioning normally now.
Posted Mar 26, 2025 - 08:43 PDT

Update

We are continuing to investigate this issue.
Posted Mar 26, 2025 - 08:41 PDT

Update

To address sign on difficulty with ServiceNow, please delete your browser's cache/browsing history for the past 7 days. This has been found to work for many people. Alternatively, signing in using Incognito mode has also worked. We continue to investigate the underlying issue to find a permanent solution.
Posted Mar 24, 2025 - 10:08 PDT

Investigating

We are investigating reports of individuals having difficulty signing in ServiceNow.
Posted Mar 24, 2025 - 09:20 PDT
This incident affected: Campus Technical Services (ServiceNow).