Kronos Issue

Incident Report for UCSB

Resolved

This incident has been resolved.
Posted Apr 23, 2025 - 12:41 PDT

Update

Access to the Timekeeping system has been restored, and users should now be able to log in successfully through Single Sign-On (SSO).

Please note that some users may still receive system messages or encounter minor issues as we continue working through the remaining items. We are actively addressing these with our vendor and monitoring system performance.

We appreciate your patience and will share further updates as needed.
Posted Apr 23, 2025 - 09:33 PDT

Monitoring

We are still investigating the timekeeping system issue.
Posted Apr 23, 2025 - 09:19 PDT

Investigating

We are currently experiencing an issue with access to the Timekeeping system. Users are able to reach the Single Sign-On (SSO) page and enter their credentials; however, instead of being directed into the application, they are being routed to the Kronos login screen.

Our team is actively investigating the issue. A Major INC has been opened, and we will also communicate directly to our Timekeeper and Payroll Manager population.
Posted Apr 23, 2025 - 08:07 PDT
This incident affected: Campus Business Applications (Electronic Timekeeping (Kronos)).