Canvas Currently Unavailable

Incident Report for UCSB

Resolved

Canvas is now available again.
Posted May 08, 2026 - 08:02 PDT

Investigating

Canvas is reporting an outage and is currently unavailable . They are investigating the issue.
Posted May 07, 2026 - 14:26 PDT