The off-campus network problem appears to have occurred within a major internet service provider's network, and has since been corrected. Network service is stable at this time. The campus network team will closely monitor for any new signs of instability.
Posted Feb 20, 2026 - 11:14 PST
Monitoring
The off-campus network problem appears to have occurred within a major internet service provider's network, and has since been corrected. Network service is stable at this time. The campus network team will closely monitor for any new signs of instability.
Posted Feb 20, 2026 - 11:13 PST
Investigating
There is evidence of network problems in one or more off-campus internet service providers. This has caused problems accessing on-campus services from certain external networks, as well as interference with UCSB's access to external services. This problem began at approximately 9:59am. Trouble tickets are being opened with external providers to initiate troubleshooting.
Posted Feb 20, 2026 - 10:38 PST
This incident affected: Campus Business Applications (BARC, Concur, Data Warehouse, Electronic Timekeeping (Kronos), ESPRESSO Applications, Gateway, Gateway Management Console (GMC), GUS, Hyperion, OnLine General Ledger (OLGL), PeopleSoft Financials, UC Learning Center, UCPATH, UCPath Operational Data Store, Docusign, Power BI).