Google Gemini Service Disruption

Incident Report for UCSB

Resolved

Incident has been resolved.
Google provided the following information:
The issue with Gemini has been resolved for all the affected users as of Wednesday, 2026-06-10 10:30 US/Pacific.

From preliminary analysis, the issue was triggered by a performance issue in our backend database which impacted the retrieval of Gemini App tools catalog.

Our engineers mitigated the issue by optimizing the load distribution across our backend database fleet.

We thank you for your patience while we worked on resolving the issue.
Posted Jun 11, 2026 - 07:10 PDT

Investigating

Google is reporting the following:
Symptoms

Gemini App in Workspace and Gemini Side Panel (Gemini in Workspace) customers are experiencing “Something Went Wrong” errors.

Workaround

None at this time.
Posted Jun 10, 2026 - 07:46 PDT
This incident affected: Messaging, Collaboration, and Communication Services (Google Gemini).