Network Down at Embarcadero Hall

Incident Report for UCSB

Resolved

This incident has been resolved.
Posted Jun 14, 2024 - 14:05 PDT

Update

We are continuing to investigate this issue.
Posted Jun 14, 2024 - 14:03 PDT

Investigating

Network service was restored to Embarcadero Hall at 12:31 pm today
Posted Jun 14, 2024 - 02:00 PDT