Google Services - Degraded Services
Incident Report for UCSB
Resolved
Google reports all issues have been resolved. If you continue to experience any technical difficulties with Google Services, please report them to your IT service provider or contact 805-893-5000.
Posted Mar 26, 2020 - 10:42 PDT
Investigating
Google is reporting several degraded services. They are investigating and updates will be provided as they become available.
Posted Mar 26, 2020 - 09:17 PDT
This incident affected: Messaging, Collaboration, and Communication Services (Google Apps Gmail, Google Apps Hangouts, Google Drive, Other Google Services).