Our technical teams have identified the issues, and implemented a fix to resolve the issues affecting the Student Information System (SIS) and Admissions screens. Systems are beginning to stabilize, and users should now be able to resume normal operations. We are closely monitoring performance to ensure full stability and will provide a final update once we are confident the issue is completely resolved.
Posted May 21, 2026 - 09:58 PDT
Investigating
We are actively troubleshooting a technical issue affecting central database services that is causing disruptions across portions of the Student Information System (SIS). This issue is primarily impacting a subset of staff users, though students may also experience intermittent errors or loading issues within GOLD. Our technical teams are fully engaged in finding a resolution, and we will provide our next update within the hour.
Posted May 21, 2026 - 09:26 PDT
This incident affected: Student Affairs Services (Student Affairs Sites and Services).