Google Connect: Email Disappearing

Incident Report for UCSB

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 08:57 PDT

Update

All messages quarantined erroneously between 12:05-1:10pm today have been restored to Inboxes as of 4:40pm.

Users using the Google Gmail web interface or Gmail app may see a later timestamp displayed on these messages from when they were originally sent and delivered.
Posted Jun 09, 2025 - 18:03 PDT

Monitoring

Messages are being returned to Inboxes as we work through the Quarantine backlog. Thank you for your patience and understanding.
Posted Jun 09, 2025 - 15:16 PDT

Identified

We received reports of Gmail messages appearing and then "disappearing" from view in users' Inboxes.

A change was made in a Gmail Compliance Rule intended to Quarantine phishing messages from optonline.net domain. There was an error in the rule that caused it to affect additional email messages outside of the intended scope.

The mail rule has been reverted, and we are working to move affected messages back out of Quarantine into users' Inboxes. The messages should begin re-appearing in the next 15-30 minutes.
Posted Jun 09, 2025 - 13:40 PDT

Investigating

We are aware of an issue involving email disappearing. Currently investigating
Posted Jun 09, 2025 - 13:14 PDT
This incident affected: Messaging, Collaboration, and Communication Services (Campus (UCSB) Connect Email).