FMMETASYS is down
Incident Report for UCSB
Resolved
This incident has been resolved.
Posted Feb 02, 2023 - 19:20 PST
Investigating
Service Outage Notification
Posted Feb 02, 2023 - 19:18 PST
This incident affected: Administrative Services Applications (MetaSys).