Timekeeping Service Degradation

Incident Report for UCSB

Monitoring

UKG has reported that the service degradation has been resolved. We will confirm and monitor services/interfaces during the weekend.
The status of this incident has been changed to monitoring.
As always, thank you for your patience and support.
Posted Sep 11, 2026 - 16:25 PDT

Investigating

UKG Pro Workforce Management is currently experiencing a service degradation affecting database performance, which may prevent users from editing schedules and approving requests. The vendor is working diligently to restore normal system access as quickly as possible.
Posted Sep 11, 2026 - 08:38 PDT
This incident affects: Campus Business Applications (Electronic Timekeeping (Kronos)).