Major Incident Tracking - ServiceNow

Incident Report for UCSB

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 14:45 PDT

Investigating

We are receiving reports of individuals unable to sign into ServiceNow. This is being investigated.
Posted Jul 14, 2025 - 13:42 PDT
This incident affected: Campus Technical Services (ServiceNow).