DOU received an update from their vendor who have implemented a fix and affected devices will no longer see notification delivery issues as this fix rolls out over the next couple hours.
Monitoring will continue until full confirmation of resolution is achieved.
Posted Oct 05, 2023 - 17:01 PDT
Update
Duo continues to work with their vendor to determine how to best mitigate the issue.
Posted Oct 05, 2023 - 16:37 PDT
Identified
DOU has reported that the issue has been partially identified at this time, and they are working with their vendor to determine how to best mitigate the issue. They are currently awaiting more details in order to begin working on a fix.
Posted Oct 05, 2023 - 12:36 PDT
Investigating
DUO is investigating an issue with users not getting Duo Push notifications when completing MFA. Originally, DUO thought it was affecting iOS and Android devices. Just recently, they found the issue is isolated to Android devices. If you are experiencing issues, you can open the Duo Mobile application to trigger the approve/deny authentication workflow as a temporary workaround.
Posted Oct 05, 2023 - 08:49 PDT
This incident affected: Campus Identity and Authentication Services (Duo Push Delivery).