Major Incident Tracking - PeopleSoft Financials
Incident Report for UCSB
Resolved
This incident has been resolved.
Posted Aug 22, 2024 - 08:07 PDT
Investigating
We are aware of an issue with PeopleSoft. The responsible service operators have been notified and an investigation is proceeding.
Posted Aug 21, 2024 - 14:42 PDT
This incident affected: Campus Business Applications (PeopleSoft Financials).