ucsb.service-now.com degraded performance

Incident Report for UCSB

Resolved

This incident has been resolved.
Posted Jan 28, 2025 - 15:23 PST

Investigating

We are aware of an issue with ucsb.service-now.com. The responsible service operators have been notified and an investigation is proceeding.
Posted Jan 28, 2025 - 14:43 PST
This incident affected: Campus Technical Services (ServiceNow).