This is resolved and was related to legacy DNS names for Duo not being updated during a tenant move initiated by the vendor.
Posted Jun 25, 2024 - 11:32 PDT
Update
We continue to work with DUO on the device registration page. At this time we don't have a resolution. We do have a workaround that you can use. Please see below. WORKAROUND: if you need to add a device (another cell phone), if you try any Duo login, like SSO, the prompt (window) will provide an "Add a New Device" and "My Settings & Devices". You can use these options to get the same functionality.
Posted Jun 25, 2024 - 10:11 PDT
Investigating
We are aware of a possible issue with the Campus DUO Customer Portal https://duo-mgmt.identity.ucsb.edu/. The responsible service operators have been notified and an investigation is proceeding.
Posted Jun 24, 2024 - 16:42 PDT
This incident affected: Campus Identity and Authentication Services (Duo Core Authentication Service).