Chrome SSL Certificate Prompt

Incident Report for UCSB

Resolved

Google has posted that they have resolved this incident. The issue was due to a configuration error that inadvertently requested client certificates. Their engineers have mitigated the issue by fully rolling back the affected configurations to a previous working state.
Posted Jun 17, 2026 - 08:12 PDT

Investigating

People are reporting issues with certain webpages prompting for Certificates. This is a known issue and, unfortunately, out of our hands. Google is aware and we are waiting for updates from them.
Posted Jun 16, 2026 - 15:58 PDT
This incident affected: Messaging, Collaboration, and Communication Services (Google Chrome).