This is the final all-clear message. Isolated building-specific issues will be communicated via https://status.arit.ucsb.edu/
Posted Mar 28, 2025 - 12:16 PDT
Verifying
Power service to the campus has been restored. Facilities Management will be checking system functionality at campus facilities and a final 'all clear' message will be sent when all major systems are operational.
Posted Mar 28, 2025 - 08:07 PDT
Update
The scheduled power service interruption and related infrastructure maintenance are progressing as expected. We will provide further updates as they become available. Thank you for your patience and cooperation during this essential work.
Posted Mar 28, 2025 - 01:34 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 27, 2025 - 21:00 PDT
Scheduled
The Public Utilities Commission has directed Southern California Edison (SCE) to perform upgrades on the power transmission systems serving the campus. The work entails repairs on the vault located on Los Carneros Road, repairs to the Remote Transmission Switch that leads to the Colegio Substation, and a deteriorated pole replacement. This work will require a power service interruption (i.e. power outage) to the UC Santa Barbara main campus and all areas served by the campus electrical distribution system.
SCE expects their portion of the outage to be over before noon on Friday, March 28. Once power has been restored, Facilities Management will re-energize campus and check all building systems to ensure they are operating, and will provide updates via Statuspage.
For your safety, we recommend you vacate all non-residential buildings by 8 p.m. Thursday, March 27.
The planned service interruption will impact UC Santa Barbara properties and facilities only, including all main campus buildings and a number of adjacent housing and dining facilities that receive their electrical power service directly from campus.
Faculty housing in the Ocean Walk and West Campus developments are on separate circuits and will not be impacted.
A planning process is currently underway to identify and address the needs of our campus community. Please visit the Planned Power Outage webpage so you can see how to prepare your area.