WebTMA is down

Incident Report for UCSB

Resolved

This incident has been resolved.
Posted Nov 28, 2019 - 00:31 PST

Investigating

Service Outage Notification
Posted Nov 28, 2019 - 00:28 PST
This incident affected: Administrative Services Applications (iServiceDesk - WebTMA).