Service Disruption - Duo Mobile Self-Registration

Incident Report for UCSB

Resolved

This incident has been resolved. Apologies for the inconvenience.
Posted Aug 15, 2024 - 15:15 PDT

Investigating

We have identified that Duo self-registration is currently inoperative. We are looking into the cause and will update when we have more information.
Posted Aug 15, 2024 - 15:05 PDT