WebTMA 7 is down

Incident Report for UCSB

Resolved

This incident has been resolved.
Posted Jun 20, 2026 - 12:44 PDT

Investigating

Service Outage Notification
Posted Jun 20, 2026 - 12:33 PDT
This incident affected: Administrative Services Applications (iServiceDesk - WebTMA).